載入中...
在線檢測未來函數
載入中...

通達信支撐與壓力的神級主圖指標公式

來源:Internet,編輯:股旁網,2018-09-28

局部低點預選A:=BACKSET(LLV(L,5)<REF(LLV(L,4),1),4);
局部低點預選B:=BACKSET(局部低點預選A=0 AND REF(局部低點預選A,1)=1,2);
局部低點預選C:=IF(局部低點預選B=1 AND REF(局部低點預選B,1)=0,-1,0);
局部高點預選A:=BACKSET(HHV(H,5)>REF(HHV(H,4),1),4);
局部高點預選B:=BACKSET(局部高點預選A=0 AND REF(局部高點預選A,1)=1,2);
局部高點預選C:=IF(局部高點預選B=1 AND REF(局部高點預選B,1)=0,1,0);
缺口判斷:=IF(L>REF(H,1),1,IF(H<REF(L,1),-1,0));
距前高天:=BARSLAST(局部高點預選C=1);
距前低天:=BARSLAST(局部低點預選C=-1);
小值周期:=LOWRANGE(L);
大值周期:=TOPRANGE(H);
低保留AA:=IF(局部低點預選C=-1 AND REF(距前高天,1)>REF(距前低天,1) AND LLV(L,距前高天+1)<REF(LLV(L,距前高天+1),1),-1,0);
低保留AB:=IF(局部低點預選C=-1 AND REF(距前高天,1)<=REF(距前低天,1) AND (距前高天>=4 OR LLV(缺口判斷,距前高天)=-1 OR LLV(L,距前低天+2)<REF(LLV(L,距前低天+1),1)),-1,0);
低保留S:=IF((低保留AA=-1 OR 低保留AB=-1) AND L<REF(H,距前高天+1),-1,0);
預判:=IF((距前低天<4 AND HHV(缺口判斷,距前低天)!=1) OR REF(低保留S,距前低天)=0,1,0);
判斷:=IF(局部高點預選C=1 AND REF(距前低天,1)<=REF(距前高天,1) AND 預判=1 AND 大值周期>REF(小值周期,距前低天+1) AND 大值周期>REF(小值周期,距前低天) AND 大值周期>REF(大值周期,距前高天),1,0);
高保留A:=IF(局部高點預選C=1 AND REF(距前低天,1)>REF(距前高天,1) AND HHV(H,距前低天+1)>REF(HHV(H,距前低天+1),1),1,0);
高保留B:=IF(局部高點預選C=1 AND REF(距前低天,1)<=REF(距前高天,1) AND REF(低保留S,距前低天)=-1 AND (距前低天>=4 OR HHV(缺口判斷,距前低天)=1),1,0);
高保留:=IF((高保留A=1 OR 高保留B=1 OR 判斷=1) AND H>REF(L,距前低天+1),1,0);
預判A:=IF((距前高天<4 AND HHV(缺口判斷,距前高天)!=1) OR REF(高保留,距前高天)=0,1,0);
判斷A:=IF(局部低點預選C=-1 AND REF(距前高天,1)<=REF(距前低天,1) AND 預判A=1 AND 小值周期>REF(大值周期,距前高天+1) AND 小值周期>REF(大值周期,距前高天) AND 小值周期>REF(小值周期,距前低天),-1,0);
低保留A:=IF(局部低點預選C=-1 AND REF(距前高天,1)>REF(距前低天,1) AND LLV(L,距前高天+1)<REF(LLV(L,距前高天+1),1),-1,0);
低保留B:=IF(局部低點預選C=-1 AND REF(距前高天,1)<=REF(距前低天,1) AND (距前高天>=4 OR LLV(缺口判斷,距前高天)=-1 OR 判斷A=-1),-1,0);
低保留:=IF((低保留A=-1 OR 低保留B=-1) AND L<REF(H,距前高天+1),-1,0);
距前高天A:=BARSLAST(高保留=1);
距前低天A:=BARSLAST(低保留=-1);
預判X:=IF((距前低天A<4 AND HHV(缺口判斷,距前低天A)!=1) OR REF(低保留,距前低天A)=0,1,0);
判斷X:=IF(局部高點預選C=1 AND REF(距前低天A,1)<=REF(距前高天A,1) AND 預判X=1 AND 大值周期>REF(小值周期,距前低天A+1) AND 大值周期>REF(小值周期,距前低天A) AND 大值周期>REF(大值周期,距前高天A),1,0);
高保留XA:=IF(局部高點預選C=1 AND REF(距前低天A,1)>REF(距前高天A,1) AND HHV(H,距前低天A+1)>REF(HHV(H,距前低天A+1),1),1,0);
高保留XB:=IF(局部高點預選C=1 AND REF(距前低天A,1)<=REF(距前高天A,1) AND REF(低保留,距前低天A)=-1 AND (距前低天A>=4 OR HHV(缺口判斷,距前低天A)=1),1,0);
高保留X:=IF((高保留XA=1 OR 高保留XB=1 OR 判斷X=1) AND H>REF(L,距前低天A+1),1,0);
預判XA:=IF((距前高天A<4 AND HHV(缺口判斷,距前高天A)!=1) OR REF(高保留XA,距前高天A)=0,1,0);
判斷XA:=IF(局部低點預選C=-1 AND REF(距前高天A,1)<=REF(距前低天A,1) AND 預判XA=1 AND 小值周期>REF(大值周期,距前高天A+1) AND 小值周期>REF(大值周期,距前高天A) AND 小值周期>REF(小值周期,距前低天A),-1,0);
低保留XA:=IF(局部低點預選C=-1 AND REF(距前高天A,1)>REF(距前低天A,1) AND LLV(L,距前高天A+1)<REF(LLV(L,距前高天A+1),1),-1,0);
低保留XB:=IF(局部低點預選C=-1 AND REF(距前高天A,1)<=REF(距前低天A,1) AND (距前高天A>=4 OR LLV(缺口判斷,距前高天A)=-1 OR 判斷XA=-1),-1,0);
低保留X:=IF((低保留XA=-1 OR 低保留XB=-1) AND L<REF(H,距前高天A+1),-1,0);
距前高天YA:=BARSLAST(高保留X=1);
距前低天YA:=BARSLAST(低保留X=-1);
預判YX:=IF((距前低天YA<4 AND HHV(缺口判斷,距前低天YA)!=1) OR REF(低保留X,距前低天YA)=0,1,0);
判斷YX:=IF(局部高點預選C=1 AND REF(距前低天YA,1)<=REF(距前高天YA,1) AND 預判YX=1 AND 大值周期>REF(小值周期,距前低天YA+1) AND 大值周期>REF(小值周期,距前低天YA) AND 大值周期>REF(大值周期,距前高天YA),1,0);
高保留YXA:=IF(局部高點預選C=1 AND REF(距前低天YA,1)>REF(距前高天YA,1) AND HHV(H,距前低天YA+1)>REF(HHV(H,距前低天YA+1),1),1,0);
高保留YXB:=IF(局部高點預選C=1 AND REF(距前低天YA,1)<=REF(距前高天YA,1) AND REF(低保留X,距前低天YA)=-1 AND (距前低天YA>=4 OR HHV(缺口判斷,距前低天YA)=1),1,0);
高保留YX:=IF((高保留YXA=1 OR 高保留YXB=1 OR 判斷YX=1) AND H>REF(L,距前低天YA+1),1,0);
預判YXA:=IF((距前高天YA<4 AND HHV(缺口判斷,距前高天YA)!=1) OR REF(高保留YXA,距前高天YA)=0,1,0);
判斷YXA:=IF(局部低點預選C=-1 AND REF(距前高天YA,1)<=REF(距前低天YA,1) AND 預判YXA=1 AND 小值周期>REF(大值周期,距前高天YA+1) AND 小值周期>REF(大值周期,距前高天YA) AND 小值周期>REF(小值周期,距前低天YA),-1,0);
低保留YXA:=IF(局部低點預選C=-1 AND REF(距前高天YA,1)>REF(距前低天YA,1) AND LLV(L,距前高天YA+1)<REF(LLV(L,距前高天YA+1),1),-1,0);
低保留YXB:=IF(局部低點預選C=-1 AND REF(距前高天YA,1)<=REF(距前低天YA,1) AND (距前高天YA>=4 OR LLV(缺口判斷,距前高天YA)=-1 OR 判斷YXA=-1),-1,0);
低保留YX:=IF((低保留YXA=-1 OR 低保留YXB=-1) AND L<REF(H,距前高天YA+1),-1,0);
AAAD:=IF(高保留YX=1 AND 低保留YX=-1 AND H>REF(H,REF(距前高天YA,1)+2),1,IF(高保留YX=1 AND 低保留YX=-1 AND L<REF(L,REF(距前低天YA,1)+2),-1,0));
極點保留:=IF(AAAD=0,高保留YX+低保留YX,AAAD);
XA:=DRAWLINE(極點保留=-1,L,REF(極點保留,1)=-1,REF(L,1),1);
XB:=DRAWLINE(極點保留=1,H,REF(極點保留,1)=1,REF(H,1),1);
XAS:=DRAWLINE(極點保留=-1,XB,REF(極點保留,1)=-1,REF(XB,1),1);
XBS:=DRAWLINE(極點保留=1,XA,REF(極點保留,1)=1,REF(XA,1),1);
XA45:=(XA+XAS)/2; XB45:=(XB+XBS)/2;
XA63:=(XAS-XA)*3/4+XA; XB63:=XB-(XB-XBS)*3/4;
DRAWBAND(XA45,RGB(0,150,100),XA63,RGB(0,150,100));
DRAWBAND(XB45,RGB(185,96,9),XB63,RGB(185,96,9));
局部極點:IF(極點保留=-1,L,IF(極點保留=1,H,DRAWNULL)),CIRCLEDOT,COLORYELLOW,LINETHICK5;
壓1:IF(BETWEEN(XA45,XB45,XB63),XA45,DRAWNULL),COLOR008800;
壓2:IF(BETWEEN(XA63,XB45,XB63),XA63,DRAWNULL),COLOR008800;
過壓底:REF(C,1)<XA45 AND C>XA45 AND C<35 AND CAPITAL<6000000,COLORYELLOW,NODRAW;
過壓頂:REF(C,1)<XA63 AND C>XA63 AND C<35 AND CAPITAL<6000000,NODRAW;
支撐底:REF(C,1)<XB63 AND C>XB63 AND C<35 AND CAPITAL<6000000,NODRAW;
支撐頂:REF(C,1)<XB45 AND C>XB45 AND C<35 AND CAPITAL<6000000,NODRAW;
DRAWKLINE(HIGH,OPEN,LOW,CLOSE);
量5:=EMA(EMA(VOL,5),5);
量35:=EMA(EMA(VOL,35),35);
VAR11:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
成交:=VOL;
主買:=IF(CLOSE>OPEN,VAR11*(HIGH-LOW),IF(CLOSE<OPEN,VAR11*((HIGH-OPEN)+(CLOSE-LOW)),VOL/2)),COLOR00E521;
主賣:=IF(CLOSE>OPEN,VAR11*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,VAR11*(HIGH-LOW),VOL/2));
主買力度:=VOL/(主買-主賣);
買賣比:=主買/主賣;
昨日比:=買賣比/REF(買賣比,1);
凈買: (主買-主賣)/100,NODRAW;
搶籌:=買賣比>4,NODRAW;
BB:=凈買<0;
凈買天數:BARSLAST(BB),COLORMAGENTA,NODRAW;
STICKLINE(凈買>0,C,O,3,0),COLORRED;
STICKLINE(凈買<0,C,O,1.8,0),COLORGREEN;
STICKLINE(搶籌,C,O,2,0),COLORYELLOW;
STICKLINE(主買力度>9,H,O,3,0),COLORWHITE;

通達信支撐與壓力的神級主圖指標公式

 

相關文章

捕鱼游戏子类别 新浪彩票工具今日运势 安徽体彩中心兑奖时间 彩易科思合作的竞彩app 一肖中特准中网 大发快三单双破解器 重庆百变王牌48期开奖 浙江体彩大乐透走势图超长板 一码中特公开认证 秒速时时规律2017 四川福彩快乐12官方app 腾讯分分彩都是统一开奖的吗 重庆时时过年会停吗 天津时时号码记录 广西快乐十分官方下载 秒速时时彩开奖记录app 广东时时现场开奖